Cómo instalar Pagekit CMS en Debian 9

Instalador web de Pagekit

Pagekit es un CMS moderno, intuitivo, modular y flexible de código abierto (licencia MIT) construido con componentes Symfony y Vue.js. Le brinda las herramientas para crear hermosos sitios web. Tiene un rico ecosistema de temas y complementos.

En este tutorial, lo guiaremos a trav√©s del proceso de instalaci√≥n de Pagekit CMS en un sistema operativo Debian 9 (extendido) usando NGINX como servidor web, MariaDB como servidor de base de datos y, opcionalmente, puede proteger la capa de transporte usando el cliente acme.sh y la autoridad de certificaci√≥n Let’s Encrypt para agregar compatibilidad con SSL.

Requisitos

Para instalar Pagekit, aseg√ļrese de que su servidor cumpla con los siguientes requisitos:

  • Apache versi√≥n 2.2 o superior o servidor web NGINX.
  • MySQL versi√≥n 5.1 o superior o SQLite 3.
  • PHP versi√≥n 5.5.9 o superior.
  • Extensiones PHP requeridas: JSON, Session, ctype, Tokenizer, SimpleXML, DOM, mbstring, PCRE 8.0+, ZIP y PDO con controladores MySQL o SQLite.
  • Extensiones de PHP opcionales: cURL, iconv y XML Parser, as√≠ como APC o XCache para el almacenamiento en cach√©.
  • Un sistema que ejecuta Debian 9 (stretch).
  • Un usuario no root con privilegios sudo.

Pasos iniciales

Compruebe la versión de su sistema Debian:

lsb_release -ds
# Debian GNU/Linux 9.7 (stretch)

Configurar la zona horaria:

dpkg-reconfigure tzdata

Actualice los paquetes de su sistema operativo (software). Este es un primer paso importante porque garantiza que tenga las √ļltimas actualizaciones y correcciones de seguridad para los paquetes de software predeterminados de su sistema operativo:

apt update && apt upgrade -y

Instale algunos paquetes esenciales que son necesarios para la administración básica del sistema operativo Debian:

apt install -y curl wget vim git sudo unzip socat bash-completion dirmngr apt-transport-https

Paso 1: instale PHP y las extensiones de PHP necesarias

La plataforma Pagekit CMS requiere PHP versión 7.0 o superior. De forma predeterminada, Debian 9 tiene la versión 7.0 de PHP en sus repositorios de software predeterminados, lo que está bien para el CMS de octubre.

Descargue e instale PHP 7.0 y las extensiones de PHP requeridas:

sudo apt install -y php7.0 php7.0-cli php7.0-fpm php7.0-common php7.0-mbstring php7.0-zip php7.0-mysql php7.0-sqlite3 php7.0-curl php7.0-xml

Para mostrar PHP compilado en módulos, puede ejecutar:

php -m
ctype
curl
exif
fileinfo
. . .
. . .

Compruebe la versión de PHP:

php --version
# PHP 7.0.33-0+deb9u1 (cli) (built: Dec 7 2018 11:36:49) ( NTS )
# Copyright (c) 1997-2017 The PHP Group
# Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
#     with Zend OPcache v7.0.33-0+deb9u1, Copyright (c) 1999-2017, by Zend Technologies

El servicio PHP-FPM se inicia y habilita automáticamente al reiniciar en el sistema Debian 9, por lo que no es necesario iniciarlo y habilitarlo manualmente. Podemos pasar al siguiente paso, que es la instalación y configuración de la base de datos.

Paso 2: instale MariaDB y cree una base de datos para Pagekit

Pagekit CMS admite bases de datos MySQL, MariaDB y SQLite. El equipo de Debian reemplazó MySQL con MariaDB como la base de datos predeterminada de Debian 9 (stretch), por lo que en este tutorial usaremos MariaDB como el servidor de la base de datos. Si desea instalar MySQL original, puede agregar y usar el repositorio MySQL oficial mantenido por Oracle.

Instale el servidor de base de datos MariaDB versión 10.2 desde el repositorio oficial de MariaDB:

sudo apt install -y software-properties-common dirmngr apt-transport-https
sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 0xF1656F24C74CD1D8
sudo add-apt-repository 'deb [arch=amd64,i386,ppc64el] https://mirrors.nxthost.com/mariadb/repo/10.2/debian stretch main'
sudo apt update
sudo apt install -y mariadb-server

NOTA: Se le solicitar√° la contrase√Īa de usuario ra√≠z. Ingrese una contrase√Īa segura y contin√ļe.

Compruebe la versión de MariaDB:

mysql --version
# mysql  Ver 15.1 Distrib 10.2.22-MariaDB, for debian-linux-gnu (x86_64) using readline 5.2

Ejecute el script de instalaci√≥n mysql_secure para mejorar la seguridad de MariaDB y establezca la contrase√Īa para el usuario root de MariaDB:

sudo mysql_secure_installation

Contesta cada una de las preguntas:

Enter current password for root (enter for none): Press Enter
Set root password? [Y/n] Y
New password: your_secure_password
Re-enter new password: your_secure_password
Remove anonymous users? [Y/n] Y
Disallow root login remotely? [Y/n] Y
Remove test database and access to it? [Y/n] Y
Reload privilege tables now? [Y/n] Y

Inicie sesión en MariaDB como usuario root:

sudo mysql -u root -p
# Enter password

Cree una base de datos MariaDB y un usuario que usará para su instalación de Pagekit, y recuerde las credenciales:

CREATE DATABASE dbname;
GRANT ALL ON dbname.* TO 'username' IDENTIFIED BY 'password';
FLUSH PRIVILEGES;

Salga del shell de MariaDB:

quit

Paso 3: instale el cliente Acme.sh y obtenga el certificado Let’s Encrypt (opcional)

No es necesario proteger su sitio web con HTTPS, pero es una buena pr√°ctica para asegurar el tr√°fico de su sitio. Para obtener un certificado SSL de Let’s Encrypt utilizaremos el cliente Acme.sh. Acme.sh es un software de shell UNIX puro para obtener certificados SSL de Let’s Encrypt sin dependencias.

Descargue e instale acme.sh:

sudo su - root
git clone https://github.com/Neilpang/acme.sh.git
cd acme.sh 
./acme.sh --install --accountemail [email protected]
source ~/.bashrc
cd ~

Compruebe la versión de acme.sh:

acme.sh --version
# v2.8.1

Obtener RSA y ECC/ECDSA certificados para su dominio/nombre de host:Anuncio

# RSA 2048
acme.sh --issue --standalone -d example.com --keylength 2048
# ECDSA
acme.sh --issue --standalone -d example.com --keylength ec-256

Si desea certificados falsos para realizar pruebas, puede agregar el indicador –staging a los comandos anteriores.

Para enumerar sus certificados emitidos, puede ejecutar:

acme.sh --list

Cree un directorio para almacenar sus certificados. Usaremos el directorio /etc/letsencrypt.

mkdir -p /etc/letsencrypt/example.com
sudo mkdir -p /etc/letsencrypt/example.com_ecc

Instalar/copiar certificados en el directorio /etc/letsencrypt.

# RSA
acme.sh --install-cert -d example.com \ 
--cert-file /etc/letsencrypt/example.com/cert.pem \
--key-file /etc/letsencrypt/example.com/private.key \
--fullchain-file /etc/letsencrypt/example.com/fullchain.pem \
--reloadcmd "sudo systemctl reload nginx.service"

# ECC/ECDSA

acme.sh --install-cert -d example.com --ecc \
--cert-file /etc/letsencrypt/example.com_ecc/cert.pem \
--key-file /etc/letsencrypt/example.com_ecc/private.key \
--fullchain-file /etc/letsencrypt/example.com_ecc/fullchain.pem \
--reloadcmd "sudo systemctl reload nginx.service"

Después de ejecutar los comandos anteriores, sus certificados y claves estarán en:

  • Para RSA: directorio /etc/letsencrypt/example.com.
  • Para ECC/ECDSA: directorio /etc/letsencrypt/example.com_ecc.

Todos los certificados se renovarán automáticamente cada 60 días.

Después de obtener los certificados, salga del usuario raíz y regrese al usuario sudo normal:

exit

Paso 4: instale NGINX y configure NGINX para Pagekit

Instale el servidor web NGINX:

sudo apt install -y nginx

Compruebe la versión de NGINX:

sudo nginx -v
# nginx version: nginx/1.10.3

Configure NGINX para Pagekit ejecutando:

sudo vim /etc/nginx/sites-available/pagekit.conf

Y complete el archivo con la siguiente configuración:

server {
listen [::]:443 ssl http2;
listen 443 ssl http2;
    listen [::]:80;
    listen 80;
    
    server_name example.com;
    
    index index.php index.html;
    root /var/www/pagekit;
ssl_certificate /etc/letsencrypt/example.com/fullchain.pem;
ssl_certificate_key /etc/letsencrypt/example.com/private.key;
ssl_certificate /etc/letsencrypt/example.com_ecc/fullchain.pem;
ssl_certificate_key /etc/letsencrypt/example.com_ecc/private.key;
location / {
        try_files $uri $uri/ /index.php?$query_string;
    }
location ~ \.php$ {
include snippets/fastcgi-php.conf;
fastcgi_pass unix:/var/run/php/php7.0-fpm.sock;
} }

Active la nueva configuración de pagekit.conf vinculando el archivo al directorio habilitado para sitios.

sudo ln -s /etc/nginx/sites-available/pagekit.conf /etc/nginx/sites-enabled

Verifique la configuración de NGINX para errores de sintaxis:

sudo nginx -t

Recargar servicio NGINX:

sudo systemctl reload nginx.service

Paso 5: descargue e instale Pagekit CMS

Cree un directorio raíz de documentos en el que debe residir Pagekit:

sudo mkdir -p /var/www/pagekit

Cambie la propiedad del directorio /var/www/pagekit a [your_user]:

sudo chown -R [your_user]:[your_user] /var/www/pagekit

Navegue a la raíz del documento:

cd /var/www/pagekit

Descargue la √ļltima versi√≥n estable de Pagekit CMS a trav√©s de wget:

wget https://github.com/pagekit/pagekit/releases/download/1.0.16/pagekit-1.0.16.zip

Descomprima el contenido de Pagekit CMS y elimine el archivo .zip descargado.

unzip pagekit-1.0.16.zip
rm pagekit-1.0.16.zip

Cambie la propiedad del directorio /var/www/pagekit a www-data.

sudo chown -R www-data:www-data /var/www/pagekit

Paso 6: complete la configuración de Pagekit

Abra su sitio en un navegador web y debería ver la siguiente página:

Instalador web de Pagekit

Haga clic en el icono de la flecha hacia la derecha para continuar con la instalaci√≥n. Elija su idioma y haga clic en el bot√≥n ¬ęSiguiente¬Ľ:

Elige lengua

A continuaci√≥n, elija su base de datos, ya sea SQLite o MySQL, complete los campos obligatorios y haga clic en el bot√≥n ¬ęSiguiente¬Ľ:

Conectar a la base de datos

Después de eso, configure su sitio ingresando al Título del sitio y creando una cuenta de usuario administrador:

Configurar sitio web

Y eso deber√≠a ser todo. Ser√° redirigido a la p√°gina de inicio de sesi√≥n de Pagekit. Proporcione su nombre de usuario y contrase√Īa para iniciar sesi√≥n en el panel de control de Pagekit.

Inicie sesión en el área de administración de pagekit

Eso es todo. Si te atascaste, consulta los documentos oficiales de Pagekit.

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *