Cómo instalar vyOS RouterOS con KVM

crear nueva vm

vyOS es un cortafuegos gratuito y de código abierto basado en Debian Linux. vyOS puede ser desplegado tanto en la virtualización como en la nube, soporta KVM, VMWare, Proxmox, Hyper-V, Nutanic, Xen, etc. vyOS puede ser utilizado como un router y una plataforma de cortafuegos, proporciona enrutamiento de red basado en software, cortafuegos, VPN y seguridad.

En este tutorial, le mostraremos cómo instalar y configurar el router vyOS en una máquina virtual KVM.

Requisitos previos

  • Un sistema Linux con virtualización KVM
  • Archivo ISO de vyOS
  • Una máquina cliente Linux

Crear una máquina virtual vyOS

Para crear una nueva máquina virtual para el vyOS, puede utilizar el modo de línea de comandos desde el terminal o utilizar la aplicación GUI usando virt-manager.

En este tutorial, usted creará una máquina virtual de vyOS utilizando la aplicación GUI virt-manager.

Abra su virt-manager y crear una nueva máquina virtual.

crear nueva vm

Seleccione la opción de instalar desde el medio ISO y haga clic en Adelante.

fuente iso

Seleccione el archivo ISO del vyOS y elija el sistema operativo a instalar en Debian 11 y haga clic en Adelante.

elegir iso y tipo de sistema

Introduzca el tamaño de la memoria para el vyOS y las CPUs y luego haga clic en Reenviar.

configuración de ram y cpus

Introduzca el tamaño del disco para la instalación de vyOS y haga clic en Reenviar.

configuración del tamaño del disco

Cambia el nombre a vyos y para el Red selección, seleccionar NAT por defecto y haga clic en Finalizar.

cambiar el nombre y configurar la red

Ahora ha creado la máquina virtual para vyOS.

Instalando el router vyOS

Después de crear la máquina virtual para vyOS, ahora está listo para instalar vyOS en su virtualización KVM.

Inicie la máquina virtual de vyOS y cuando esté en marcha, verá la siguiente pantalla.

Seleccione Live (amd64-vyos) y pulse ENTER.Anuncio

vyos boot

Después de que esté en marcha, inicie la sesión con el usuario por defecto vyos y un contraseña en blanco.

acceso a vyos por defecto

Para instalar vyOS en la máquina virtual, introduzca la siguiente línea de comandos.

install image
  • Pulse ENTER para confirmar y continuar la instalación.
  • Para la partición, pulse ENTER para utilizar el Auto modo.
  • Ahora pulse ENTER de nuevo para confirmar el vyOS en su disco.

instalar vyos

Ahora se va a configurar la partición y la contraseña para vyOS.

  • Introduzca Sí para confirmar y destruir la partición por defecto.
  • Para el tamaño de la partición raíz, déjelo por defecto y pulse ENTER.
  • Deje el nombre de la imagen para el vyOS por defecto y pulse ENTER para continuar.
  • Ahora pulse ENTER de nuevo para copiar la configuración por defecto config.boot a su instalación.
  • Introduzca una nueva contraseña para el vyos usuario y repite la contraseña. Por favor, utilice una contraseña fuerte para el vyos contraseña de usuario.

instalar vyos

Para completar la instalación de vyOS, se instalará GRUB.

El instalador de vyOS detectará automáticamente su disco para la GRUB instalación. En este ejemplo, el disco es /dev/vda, ahora pulse ENTER para confirmar la instalación de GRUB.

vyos install grub

Una vez completada la instalación de GRUB, ejecute el comando reboot para reiniciar su máquina virtual vyOS.

A continuación se muestra el GRUB de la máquina virtual vyOS.

vyos install grub

Ahora inicie sesión con el usuario por defecto vyos e introduzca su contraseña. A continuación has instalado con éxito vyOS en la virtualización KVM.

inicio de sesión en vyosAnuncio

Creación de una interfaz de red adicional

En este ejemplo, configurará las interfaces de red para el vyOS.

La configuración actual del vyOS está usando la red por defecto en el tipo de virtualización KVM NAT.

Ahora creará una nueva red virtual en la virtualización KVM y adjuntará la red virtual a la máquina virtual vyOS.

En el Red Configurando virt-manager, haga clic en el botón + para añadir una nueva Red.

Introduzca el nombre y la configuración detallada de la red como se indica a continuación.

  • Nombre: interno
  • Modo: Aislado
  • Red IPv4: 192.168.50.0/24
  • DHCPv4 Inicio – Fin: 192.168.50.128 – 192.168.50.254

Haga clic en Finalizar para confirmar.

Añadir nueva interfaz KVM

Ahora apague su máquina virtual vyOS y abra la configuración de detalles de la máquina virtual vyOS, haga clic en Añadir hardware para añadir una nueva interfaz de red.

Seleccione «Red» y la «Fuente de la red» a «interno: Red aislada«. Ahora haga clic en Terminar.

Añadir una segunda interfaz de red

Ahora inicie de nuevo la máquina virtual vyOS para empezar a configurar la red vyOS.

Configurando vyOS

Ahora has adjuntado una nueva interfaz de red a la máquina virtual vyOS. A continuación, comenzará a configurar el router vyOS.

Accede a tu router vyOS usando el usuario vyos y tu contraseña fuerte.

Ahora ejecuta el comando configure para iniciar el modo de configuración en vyOS.

configure

Compruebe las interfaces de red disponibles en vyOS utilizando el siguiente comando.

ip a

Como puede ver en la captura de pantalla de abajo, en este ejemplo tenemos dos interfaces de red eth0 y eth1.

Además, al entrar en el modo de edición, verá el [edit] en el nombre de host de vyOS. También, usted notará la diferencia al entrar en el modo de edición, el shell se cambia a [email protected]#, en lugar de [email protected]:~$.

entrar en modo de edición vyos y comprobar ip

Definir WAN y LAN

Ahora has entrado en el modo de edición en vyOS. Vamos a empezar a configurar la dirección IP en vyOS.

En primer lugar, tendrá que decidir qué interfaces se utilizarán como EXTERNO/WAN y qué interfaz se utilizará como INTERNAL/LAN.

En este ejemplo, el EXTERNO/WAN la interfaz será eth0y el INTERNO/LAN será eth1 interfaz.

Configurar eth0 WAN

Ahora ejecute el siguiente comando para configurar el WAN/EXTERNO interfaz eth0.

En este ejemplo, el eth0 obtendrá una dirección IP 192.168.100.15. Además, configurará el enrutamiento estático para el eth0 a la KVM host en la dirección IP 192.168.100.1.

Después de cada cambio, ejecute el comando commit para aplicar la nueva configuración, luego ejecute save para guardar los nuevos cambios.

set interfaces ethernet eth0 address 192.168.100.15/24
set protocols static route 0.0.0.0/0 next-hop 192.168.100.1
commit
save

configuración de la WAN y configuración del enrutamiento por defecto

Configurar eth1 LAN

Ahora se va a configurar el eth1 interfaz para INTERNAL/LAN. Esta interfaz será utilizada por las máquinas virtuales bajo el router vyOS.

Ejecute el siguiente comando para configurar la dirección IP de eth1 a 192.168.50.10 y añadir la descripción para el eth1 a la interfaz LAN. Ahora confirme la configuración y guarde los cambios.

set interfaces ethernet eth1 address 192.168.50.10/24
set interfaces ethernet eth1 description LAN
commit
save

configuración de la interfaz LAN

A continuación, ejecute el siguiente comando para crear una nueva regla NAT para la interfaz LAN eth1 dirección IP 192.168.50.0/24.

Estarás creando una nueva NAT de salida para el eth1 Dirección IP 192.168.50.0/24 a la EXTERNO/WAN interfaz eth0. El tipo de NAT aquí es mascarada, luego confirme los nuevos cambios y guarde la nueva configuración.

set nat source rule 100 source address 192.168.50.0/24
set nat source rule 100 outbound-interface eth0
set nat source rule 100 translation address masquerade
commit
save

configuración nat vyos

Configurar el reenvío de DNS

Ahora configurará el reenvío de DNS en vyOS.

Ejecute el siguiente comando para configurar el Servicio de reenvío de DNS. En este ejemplo,e, el Servicio DNS se ejecutará en la dirección IP de la LAN 192.168.50.10y permitir el acceso desde la red interna eth1. A continuación, confirme la configuración y guarde los cambios.

set service dns forwarding listen-address 192.168.50.10
set service dns forwarding allow-from 192.168.50.0/24
set service dns forwarding cache-size 0
commit
save

configurar el reenvío de dns

A continuación, defina el reenvío para el servicio DNS. En este ejemplo, utilizaremos el DNS público de Cloudflare y Google como reenviador.

Ejecute el siguiente comando para configurar el reenvío de DNS a Cloudflare y Google DNS. A continuación, confirme los cambios y guarde la configuración.

set service dns forwarding name-server 1.1.1.1
set service dns forwarding name-server 8.8.8.8
commit
save

configurar reenviadores dns

Ahora ejecute el siguiente comando para cambiar el DNS de vyOS al DNS local servidor 192.168.50.10. A continuación, confirme los cambios y guarde la configuración.

set system name-server 192.168.50.10
commit
save

setup dns local vyos

Probando la configuración de la red

Ahora ha completado la configuración de la red en vyOS, esto incluye la dirección IP de la WAN, la dirección IP de la LAN y el servicio de reenvío de DNS.

Para verificar la configuración de la red, ejecute el siguiente comando para ping de Internet.

run ping youtube.com count 3

Si su configuración de red es correcta, podrá hacer ping a internet fuera de la red.

prueba de ping desde el router vyos

A continuación, ejecute el siguiente comando para comprobar las interfaces de red detalladas.

show interfaces

Ahora verá la dirección IP detallada para el eh0 y eth1 interfaces.

mostrar dirección ip

Para comprobar las reglas NAT, ejecute el siguiente comando.

show nat source rules

Ahora obtendrá la siguiente salida. El número de regla nat 100 tipos de salida NAT a la eth0 y la fuente es eth1 redes.

mostrar nat

A continuación, ejecute el siguiente comando para comprobar el servicio de reenvío de DNS.

configure
show service dns

Debería obtener una salida como la siguiente. El servicio de reenvío de DNS se está ejecutando en el eth1 interfaz 192.168.50.10 y utilizando el Cloudflare y Google servidores DNS públicos como el reenviadores.

mostrar configuración dnse

Configuración del sistema Ubuntu 20.04 para clientes

En el lado del cliente, tendrá que configurar una dirección IP estática con la puerta de enlace por defecto a la dirección Ip de vyOS 192.168.50.10. En este ejemplo, el cliente es el sistema Ubuntu 20.04.

Edite la configuración de red /etc/netplan/01-netcfg.yaml.

sudo nano /etc/netplan/01-netcfg.yaml

Copie la siguiente configuración para establecer la dirección IP estática para el sistema ubuntu.

setup static ip address netplan

Guarde y cierre el archivo cuando haya terminado.

Ahora aplique los nuevos cambios usando el comando netplan que se muestra a continuación.

sudo netplan apply

Después de eso, verifique la dirección IP en el sistema Ubuntu y verifique la tabla de enrutamiento de la red Ubuntu.

ip a
route -n

A continuación puede ver que el sistema Ubuntu tiene una dirección IP estática correcta 192.168.50.100 con la puerta de enlace por defecto de la dirección IP del vyOS 192.168.50.10.

comprobar dirección ip y enrutamiento ubuntu

Ahora ejecute el comando ping de abajo para verificar la conexión con el router vyOS.

ping 192.168.50.10 -c3

A continuación puedes ver que el cliente de Ubuntu puede conectarse al router vyOS.

ping al router vyos

A continuación, ejecute el siguiente comando para comprobar la conexión a Internet.

ping 1.1.1.1 -c3
ping google.com -c3

A continuación puedes ver que el sistema Ubuntu puede conectarse a internet a través del router vyOS.

ping a internet

Conclusión

¡Enhorabuena! Ahora has instalado y configurado el router vyOS en la virtualización KVM. Además, has aprendido cómo añadir un cliente y configurar la dirección IP estática en el lado del cliente para conectarse al router vyOS.

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *